Error on new set-up

Oct 7, 2012 at 6:28 PM

Hi,

I'm attempting to set up CrissCross for the first time on my laptop runnin Windows 7 Ultimate, SQL Server 2008 R2 Ent, IIS7 and .net 3.5.

When I load the page for the first time I see an error and this is what I see in the log file:

2012-10-07 14:01:47,548 thread5  ERROR src:CrissCross.Global         - *** Application_Error caught exception. See Elmah error log for details. Message: Exception of type 'System.Web.HttpUnhandledException' was thrown. Inner: The server did not provide a meaningful reply; this might be caused by a contract mismatch, a premature session shutdown or an internal server error.

My account is admin on my laptop.  I have windows authentication enabled on the site and I'm trying to use my own credentials to visit the site.

Also, reports manager is running and I can access it just fine here:

http://localhost:8080/Reports

What can I do to troubleshoot this error?  All suggestions welcome.

TIA,

Mark

Coordinator
Oct 7, 2012 at 10:49 PM

Hi,

Does the crisscross 'About' page respond (e.g. navigate to crisscross/About.aspx )

Also, take a look at the Elmah error log (crisscross/Elmah.axd ) ... this will give more info on the error, such as the stack trace.

Also, if I could see more of the log4net log I might be able to figure out whats going on ... if you send your Log.txt to ian@codeulike.com I'll have a look at it.

Fom what you've posted above, it seems that the SSRS web service is throwing errors or something.

Coordinator
Oct 15, 2012 at 4:39 PM

Resolved via email

Note for anyone else that has this error:

in web.config, point crisscross.ReportServerWebServiceUrl to http://your-ssrs-server/ReportServer/ReportService2005.asmx instead of http://your-ssrs-server/ReportServer/ReportService2008.asmx